Kia Telluride Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I'm writing to see if any other Telluride owners are having Blind spot warning of collision going off and not working properly? We had it in the dealership 19 days and thought it was fixed but after about 100 mile it's back. They had it in the dealership also 7 days for a low pressure AC hose leaking . We are trying to see if anyone else has or had these problems. We bought this SUV because of its size and were sold on all the safety bells and whistles but we have made 4 payments owned it for maybe 120 days and been in the two local dealerships 26 days so far. We do love it but tired of the service problems any advice out there?
 

·
Registered
Joined
·
1 Posts
I’m on two different T-ride forums and actually just posted a similar question just two days ago about my Blind Spot Monitoring System. It hasn’t worked since I bought it back in late Oct. This was in response to an earlier post...

“Just wanted to give everyone a quick update.

After three Kia dealers, it's still not fixed!

Two of the three even insisted that feature didn't come on the Telluride. The other one didn't have the time to look at it. With the two that insisted it didn't have it, it was quite "funny" when I pulled up the online Kia videos to show them. I had one service advisor even take me out to the lot to show me it wasn't on any of theirs and guess what? To his great surprise when he activated the turn signal, up popped the video camera view in the instrument cluster!

Unfortunately, I'm driving it back to the dealer I purchased it from (about 100 mi. one way) to see if they can fix it or I might consider using the state "lemon law" to return it. I can't even tell you how much time I've wasted on trying to get someone to fix this...

Has anyone else had such bad luck with Kia Dealers or is it just me?

ps - sorry for venting, I really like this car but I have had one bad experience after the other with Kia service departments..... Did I tell you about the tow hitch install? I'll save that for another time....”
 

·
Registered
Joined
·
2 Posts
I’m on two different T-ride forums and actually just posted a similar question just two days ago about my Blind Spot Monitoring System. It hasn’t worked since I bought it back in late Oct. This was in response to an earlier post...

“Just wanted to give everyone a quick update.

After three Kia dealers, it's still not fixed!

Two of the three even insisted that feature didn't come on the Telluride. The other one didn't have the time to look at it. With the two that insisted it didn't have it, it was quite "funny" when I pulled up the online Kia videos to show them. I had one service advisor even take me out to the lot to show me it wasn't on any of theirs and guess what? To his great surprise when he activated the turn signal, up popped the video camera view in the instrument cluster!

Unfortunately, I'm driving it back to the dealer I purchased it from (about 100 mi. one way) to see if they can fix it or I might consider using the state "lemon law" to return it. I can't even tell you how much time I've wasted on trying to get someone to fix this...

Has anyone else had such bad luck with Kia Dealers or is it just me?

ps - sorry for venting, I really like this car but I have had one bad experience after the other with Kia service departments..... Did I tell you about the tow hitch install? I'll save that for another time....”
As crazy as it might sound, I was actually relieved to see your posts in this forum. I was hoping there was gonna be other people with this problem and it wasn’t just me I’m sorry to say . I have had the “check Blindspot collision warning system” message on and off for more than eight months since October 2020! Unfortunately for me, there has been confusion because I was in a rear end accident when I had 900 miles on the car in August of 2020. So because the blind spot sensor and whatever that goes with it had to be replaced on the rear right passenger side, they were trying to attribute the problems to the accident. The Problem is definitely not from the accident. Furthermore, with my 2020 telluride, it seems to only be happening when it rains now. Previously it was just random in general but now after a dealer here in Long Island New York had my car for three weeks and said it was fixed, it’s now happening every time it rains.
 

·
Registered
Joined
·
2 Posts
My car is going back to the second of two dealers who already had the car for 19 days on Tuesday the day after memorial day. They want me to sign some nonsense about a $399 diagnostic fee which is definitely not happening. They also think they are going to have my car insurance company pay for the service which also isn’t happening. Happy to see there are others like me here and obviously not happy at all that we have these problems! Clearly there is a computer communication problem with this safety system that has something to do with either calibration or communication in general such as data transfer, I don’t know what it really is obviously, and neither to these dealers and their technicians. My first and last Kia purchase that’s for sure.
 
1 - 4 of 4 Posts
Top