Kia Telluride Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I'm writing to see if any other Telluride owners are having Blind spot warning of collision going off and not working properly? We had it in the dealership 19 days and thought it was fixed but after about 100 mile it's back. They had it in the dealership also 7 days for a low pressure AC hose leaking . We are trying to see if anyone else has or had these problems. We bought this SUV because of its size and were sold on all the safety bells and whistles but we have made 4 payments owned it for maybe 120 days and been in the two local dealerships 26 days so far. We do love it but tired of the service problems any advice out there?
 

·
Registered
Joined
·
60 Posts
Sorry to see you are having these problems. Most states lemon laws say 3 times for the same problem with no resolution. If they don't get it right next time, demand a replacement or for them to buy it back.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Sorry to see you are having these problems. Most states lemon laws say 3 times for the same problem with no resolution. If they don't get it right next time, demand a replacement or for them to buy it back.
Thanks going through KIA consumer affairs now and seems like they are actively involved to help us with a positive outcome
 

·
Registered
Joined
·
1 Posts
We picked up our telluride sx prestige 2 weeks ago on a Friday. Saturday morning with 25 miles on it the navigation screen wouldn’t turn on. It’s intermittent. Finally after 6 different head spins from 3 different people in just dropped it off and said call me when it’s fixed. SMH
 
1 - 5 of 5 Posts
Top